Verification is currently underway for the maintenance items.
Posted Jan 23, 2026 - 23:38 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 23, 2026 - 23:00 MST
Scheduled
We will be growing the capacity for one of our databases. As a result, there will be a small handful of short interruptions in service for all of our clients using the SalesRabbit+ application in the US region during the maintenance period. We apologize for any inconvenience this may cause and assure you that we are working diligently to minimize the impact of this outage. Our engineers are scheduling the maintenance during off-peak hours to minimize the number of affected users.
Posted Jan 23, 2026 - 13:00 MST
This scheduled maintenance affected: United States (Web App, Mobile Apps, US Public API, DataGrid: Business Search, Integrations, Digital Contracts, Batch Geocoding, DataGrid: Residential).